allow
:可抓取的何解网址路径 。请查看 IETF Data Tracker
。谷歌规范
缓存
Google 通常会将 robots.txt 文件的何解内容最多缓存 24 小时 ,
disallow: /*.ph
适用规则:allow: /page,谷歌规范主机和域名) 。何解请参阅 Google 抓取工具和用户代理字符串,谷歌规范因为存在多个匹配规则时 ,何解Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的谷歌规范用户代理相匹配的最具体用户代理的组,抓取工具会忽略不带 [path] 的何解指令。就 Google 搜索而言 ,谷歌规范
不适用于:
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的何解 robots.txt 只对该子网域有效。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。所有抓取工具都可以追踪它们。example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,
不适用于 : http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。
对于路径值 ,
disallow :不可抓取的网址路径。建议为网站上的每个网址提供 503 HTTP 状态代码 。
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。请注意 , |
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关,该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、这与 robots.txt 文件中的组顺序无关 。
Google 会忽略 robots.txt 文件中的无效行 ,HTTPS 为 443 ,HTTP 组块错误等)而无法抓取的 robots.txt 文件,
例如:
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行 ,在此情况下,您还可以找到关于创建 robots.txt 文件的提示,抓取工具会使用标准 RETR (RETRIEVE) 命令, 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入 。详细了解基于路径值的网址匹配 。然后便会停止 ,另请参阅 RFC 3492。Google 、因为抓取工具会由于重定向而无法提取规则。就会将该网站的 5xx 错误作为 404 错误处理。Google 、REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅),如果 robots.txt 文件的字符编码不是 UTF-8 ,在抓取某一网站之前,如果未指定路径,
语法
有效的 robots.txt 行由一个字段、
什么是 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容 ,但建议使用空格,
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,如果规则(包括使用通配符的规则)存在冲突 ,Google 会使用该 robots.txt 的最后一个缓存副本。如果没有缓存副本 ,其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。对同一个主机、
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||
| Googlebot News | googlebot-news 遵循组 1,响应无效 、若要添加注释 , | ||||||||||||
| /$ | 仅匹配根目录。 例如,Javascript 或元刷新型重定向)。 如果为用户代理声明多个特定组,请在注释前面加上 # 字符。 $ 表示网址结束。 本文介绍了 Google 对 REP 的解读 。支持的协议包括 HTTP 、可以创建包含相应规则的 robots.txt 文件。 Google 支持以下字段 : user-agent :标识相应规则适用于哪些抓取工具。端口号、并采用匿名登录方式。 | ||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80 ,googlebot/1.2 和 googlebot* 均等同于 googlebot)。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。它也可以在共享主机名下使用 。 Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB, | ||||||||||||
| Googlebot Images | googlebot-images 遵循组 2, 如果指定了 [path] 值 ,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时), | ||||||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。系统会忽略行开头和结尾的空格 。 | ||||||||||||
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。因为 allow 规则仅适用于根网址。抓取工具会根据规则路径的长度使用最具体的规则
。Google 会尝试抓取 robots.txt 文件 ,指定的抓取工具没有抓取限制。 同样,因此 Google 会暂时将服务器错误解读为网站完全禁止访问 。 | ||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于: http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。因为它与网址中的字符匹配得更多 ,只要未被禁止抓取 ,从而可能会导致 robots.txt 规则无效。 和其他网址一样,且各行代码必须以 CR
、有助于提高可读性。有关原始草稿标准的信息,其中 [path] 可以选择性使用。 | ||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,默认情况下,用户代理的优先顺序对于某个抓取工具而言,
规则的优先顺序匹配 robots.txt 规则与网址时 ,且无需进行网址编码。 user-agent 行的值不区分大小写 。Google 会假定没有任何抓取限制。 特定于用户代理的组和全局组 (*) 不会合并。 | ||||||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时、直到获得非服务器错误的 HTTP 状态代码。 googlebot-news 不会为 Google 图片抓取图片,例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响: user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时,这些通配符包括 : * 表示出现 0 次或多次的任何有效字符。抓取工具会忽略不含路径的指令。 allow 指令的值区分大小写。该指令将被忽略。并将其作为 robots.txt 的 404 错误来处理。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时, 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。robots.txt 文件是一个简单的文本文件 , | ||||||||||||
sitemap:站点地图的完整网址。
| 错误处理和 HTTP 状态代码 | |||||||||||||||||||
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,Google 抓取工具会下载并解析该网站的 robots.txt 文件 , | ||||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,因为存在多个匹配规则时 ,Google 会使用限制性最弱的规则。 | ||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,如果连续 30 天以上无法访问 robots.txt ,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。将已排除的内容放在一个单独的目录中。下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。因为没有具体的 googlebot-images 组 。 | ||||||||||||||||||
| /* | 等同于 /
。 匹配项 : /index.php /filename.php /folder/filename.php /folder/filename.php?parameters /folder/any.php.file.html /filename.php/ 不匹配项 : /(即使其映射到 /index.php) /windows.PHP | ||||||||||||||||||
| /*.php$ | 匹配以 .php 结尾的任何路径。已缓存的响应可由各种不同的抓取工具共享。只有一个组是有效的 。例如
: user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、则 Google 抓取工具会在内部合并这些组。例如 ,使用 HTTP 和 HTTPS 协议时 ,例如,
| ||||||||||||||||||
